
Laboratory 2 

Getting started with HFSS 

 The ANSYS Electronics Desktop, shown in the following figure, provides a 

comprehensive environment for designing and simulating various electronic components and 

devices. The Electronics Desktop consists of a unified user interface where electromagnetic 

designs, thermal designs, and circuits can be created. Typically, you can create or import a 

design, set up the simulation, validate your design, run the analysis, and post process the 

results. 

 

 The desktop includes the following design types: 

 HFSS – a general purpose 3D interface for the design, analysis, and simulation of 

electromagnetic components. 

 HFSS 3D Layout – a full-wave, layout-based electromagnetic simulator with a 

specialized interface for geometries created in layout. 

 HFSS-IE – a full-wave Integral Equation solver for large, open problems. 

Launching ANSYS Electronics Desktop 

 Once you have installed ANSYS Electronics Desktop, start the program using one of 

the following methods: 

 On the Windows desktop, click the ANSYS Electronics Desktop icon. 



 

 From the Windows Start menu, select ANSYS EM Suite 2019 R1 > ANSYS 

Electronics Desktop 2019 R1. 

ANSYS Electronics Desktop Overview 

 The ANSYS Electronics Desktop desktop consists of several windows, a menu bar, 

toolbars, and a status bar. You can customize the appearance of the desktop customizing or 

moving the toolbars, by choosing which windows to display, and by resizing and moving 

windows. Some menus, and other features change depending on the type of project that is 

loaded and the editor that is active in the Design Area. 

 

Working with Ribbons 

 The ribbon is the rectangular area across the top of the application. It comprises 

various tabs, each one representing a subset of commands available from the menus. The 

initial set of tabs (Desktop, View, Simulation, Automation) offers commands for adding and 

opening projects, selecting solvers, configuring the Desktop display (window choice, size, 

and position), configuring the simulation environment, setting scripted Event Callbacks or 

General Options, and showing Automation features for recording and using scripts. 



 

 After you open or add a project, you see additional tabs appropriate for the design and 

solver, and the tabs display additional features. 

 For example, for an HFSS project, the Draw, Model, and Results tabs appear. 

 

 For example, If you have inserted an HFSS project, the View tab displays commands 

appropriate for the active editor: 

 

Project Manager Window 

 The Project Manager window displays the open project's structure, which is referred 

to as the project tree. 

 

 The Project Manager window displays details about all open ANSYS Electronics 

Desktop projects. The tree display is specific to the design type. For example:  

 For any HFSS or Q3D design, each project ultimately includes a geometric model, its 

boundary conditions and material assignments, and field solution and post-processing 

information. Any 3D Components appear under the 3D Components icon. 



 For a Circuit design, the project includes data, excitations, ports, analysis setup, 

design verification, SoD configuration, Optimetrics, results, and relevant definitions. 

Shortcut Menus in the Project Manager Window 

 Each node, or item, in the project tree has a shortcut menu. For example, from the 

shortcut menu for the Boundaries icon, you can assign boundaries to selected objects; review 

information for all the boundary assignments for the active design; remove all boundary 

assignments; show or hide a boundary's geometry, name, or vectors; change the priority of a 

previously assigned boundary; and use the PML Setup wizard to create a perfectly matched 

layer (PML) boundary. 

 Other nodes have shortcut menus appropriate for the context. For example, the 

following figure shows the shortcut menu when you right-click the design. 

 



 

3D Modeler Window 

 The 3D Modeler window is the area where you create the model geometry. It appears 

to the right of the Project Manager window after you insert an ANSYS Electronics Desktop 

design into a project. The 3D Modeler window consists of the modeler view area, or grid, and 

the History Tree. The two areas are highlighted in the following figure: 

 

 You can open a new 3D Modeler window in one of two ways: 

 Insert a new ANSYS Electronics Desktop design into the current project, or 

 Double-click an ANSYS Electronics Desktop design in the Project Tree 



 The model you draw is saved with the current project when you click File > Save. 

Objects are drawn in the 3D Modeler window. You can create 3D objects using ANSYS 

Electronics Desktop's Draw menu commands, or you can draw 1D and 2D objects and 

manipulate them to create 3D objects. 

ANSYS Electronics Desktop History Tree 

The history tree in the 3D Modeler window lists the active model's structure and grid details. 

 

Expand or collapse items in the tree using the + and - boxes. 

Expand or collapse all items in a category by right-clicking to open a shortcut menu: 

Setting Units of Measurement for the Model 

 You can specify the units of measurement for drawing geometric models. After the 

units of measurement have been specified, they are assigned to the objects in the 3D Modeler 

window. 

 You can then choose to display the model's dimensions in the new units, or rescale the 

model's dimensions to the new units. 

 To set the model's units of measurement: 

1. Click Modeler>Units. The Set Model Units dialog box appears. 

2. Select the new units for the model from the Select units drop-down menu. 

3. Specify how the change in units affects the model: 



 Select the Rescale to new units option to rescale the dimensions to the new units. 

For example, selecting centimeters (cm) as the new unit of measurement results in 

a dimension of 10 millimeters (mm) becoming 10 cm. 

 Clear the Rescale to new units option (the default) to convert the dimensions to 

the new units without changing their scale. For example, selecting cm as the new 

unit of measurement results in a dimension of 10 mm becoming 1 cm. 

 Click OK to apply the new units to the model. 

 

 You can draw one-, two-, or three-dimensional objects using the Draw commands. 

You can alter objects individually or together to create the geometry of your structure. In the 

Tools>Modeler Options, Drawing tab, you can set a default to either draw objects directly 

with the mouse or by invoking a Properties dialog in which you can enter the values for the 

object dimensions. The Dialog mode drawing feature works with the equation based curve, 

equation based surface, and all two and three dimensional objects. You can toggle to Point 

mode via the F3 function key and to Dialog mode via the F4 function key. When you use the 

Dialog mode for drawing objects the Edit property of new primitives setting is ignored. 

 One-dimensional (1D) objects in the modeler include straight line, arc line, center-

point arc, and spline segments, or a combination of these - called polylines. One-dimensional 

objects are open objects; their boundaries do not enclose a region, unless you connect their 

endpoints. They have length, but no surface or volume. Generally they are used as temporary 

objects from which to create 2D objects. 

 Two-dimensional (2D) objects in the modeler include objects such as equation based 

surfaces, rectangles, ellipses, circles, and regular polygons. Two-dimensional objects are 

closed sheet objects; their boundaries enclose a region. You can create 2D sheet objects by 

covering the enclosed region. In many applications (FSS, antennas) it is essential to calculate 

net power flow through a surface. 

 You can also edit the properties of a polyline from the history tree to assign it a Cross 

Section property as line or rectangular. If you then assign it either a height or a width, the 

polyline becomes a sheet object. 



 By default, the history tree organizes sheet objects according to their boundary 

assignments. To change this, select the Sheets icon, and right-click to display the Group 

Sheets by Assignment check box. Within the calculator sheet objects are listed under 

surface. 

 Three-dimensional (3D) objects in the modeler include objects such as boxes, 

cylinders, regular 

polyhedra, cones, spheres, torii, and helices. These objects have boundaries that enclose a 

region with volume. You can create 3D objects by manipulating 2D objects along a plane or 

by using the appropriate Draw commands. You can also edit the properties of a polyline from 

the history tree to assign it a Cross Section property as circle rectangular. If you then assign it 

an appropriate diameter or both height or a width, the polyline becomes a 3D object. 

 You can access the Draw commands via icons on the Draw tab ribbon: 

 

 

Drawing a Sphere 

 Draw a sphere, a 3D circle, by selecting a center point and a radius. Spheres are 

drawn as true surfaces in the modeler. 

1. Click Draw>Sphere or in the Draw tab of the Ribbon, click the Sphere icon: 

 

2. Select the center point of the sphere in one of the following ways: 

 Click the point. 

 Type the point's coordinates in the text boxes in the status bar. 

3. Specify the radius by selecting a point on the sphere's circumference in one of the 

following ways: 



 Click the point. 

 Type the coordinates of the point relative to the center point in the dX, dY, and 

dZ boxes, where d is the distance from the previously selected point. 

4. Click OK. 

Drawing a Cylinder 

 Draw a cylinder by selecting a center point, radius, and height. Cylinders are drawn as 

true surfaces in the modeler. 

1. Click Draw>Cylinder or in the Draw tab of the Ribbon, click the cylinder icon: 

 

2. Select the center point of the cylinder's base circle in one of the following ways: 

 Click the point. 

 Type the point's coordinates in the text boxes in the status bar. 

3. Specify the radius by selecting a point on the base circle's circumference in one of the 

following ways: 

 Click the point. 

 Type the coordinates of the point relative to the center point in the dX, dY, and 

dZ boxes, where d is the distance from the previously selected point. 

4. Specify the cylinder's height by selecting a point on the axis perpendicular to the base 

circle's plane. Select the point by clicking the point or typing the coordinates in the 

dX, dY, and dZ boxes. 

5. Click OK. 

 

Drawing a Box 

Draw a box by selecting two diagonally opposite corners of the base rectangle, then 

specifying the height. 

1. Click Draw>Box or in the Draw tab of the ribbon, click the Box icon: 



 

2. Select the first diagonal corner of the base rectangle in one of the following ways: 

 Click the point. 

 Type the point's coordinates in the text boxes in the status bar. 

To delete the selected point and start over, press ESC or click Escape Draw Mode on the 

shortcut menu. 

3. Select the second corner of the base rectangle in one of the following ways: 

 Click the point. 

 Type the coordinates of the point relative to the first diagonal corner in the dX, 

dY, and dZ boxes, where d is the distance from the previously selected point. 

4. Specify the height of the box by selecting a point on the axis perpendicular to the base 

rectangle. Select the point by clicking the point or typing the coordinates in the dX, 

dY, and dZ boxes. 

If the Modeler option for editing properties of new primitives is checked, the Properties 

dialog box appears, enabling you to modify the object's properties. 

5. Click OK. 

Activity in the laboratory 

 You must try to familiarize yourself with HFSS interface and draw some typical 

antennas. Calculate the length as the resonant frequency is about 1.9 GHz. 

 Remember that c / f = λ and both the dipole antenna and the metal plate/monopole 

antenna use wires of  λ / 4 in length (2 for the dipole, 1 for the monopole). 

1. Draw the half-wavelength dipole antenna (square section wire, 1mm side), 1mm between 

the 2 wires (Draw Box) 

2. Draw the metal plate/monopole antenna (square section wire, 1mm side), 1mm between 

the wire and the metallic plate. Thickness of the plate is not important, side of the plate at 

least twice the length of the antenna monopole (Draw Box) 

3. Draw the same half-wavelength dipole antenna with round section wire, 1mm diameter, 

(Draw Cylinder – remember Radius = Diameter / 2) 



4. Draw the same metal plate/monopole antenna with round section wire, 1mm diameter, 

(Draw Cylinder/Box) 

Half-wavelength dipole 

5. Archive then submit the 4 projects 

 

half-wavelength dipole    metal plate/monopole 

Very Important! Remember to "Rotate" your structure to look at it from different angles to 

check correct alignment of different objects.  

Very Important! Usually better results (when drawing objects) can be obtained drawing a 

little sketch (with coordinates!!) on paper and using the Dialog input mode (press F4 function 

key to activate it or F3 to deactivate it). Drawing with the mouse on screen is a lot less 

accurate. 

 


